Payment Links service outage impacting Apple Pay

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 09:49 AEDT

Monitoring

The issue is currently fixed. Thank you for your understanding as we worked towards a solution.
Posted Mar 18, 2025 - 13:52 AEDT

Identified

We are currently experiencing a service outage affecting Payment Links, specifically impacting transactions made via Apple Pay. As a result, merchants may be unable to process these payments. Our team is actively working to resolve the issue. In the meantime, we recommend advising customers to use alternative payment methods to process transactions.
Posted Mar 17, 2025 - 14:54 AEDT
This incident affected: Payment Links.