Same Day Funding delay

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 08:53 AEST

Monitoring

There was a delay in Same Day Funding for transactions processed on Saturday, 11 April, 2026. The issue is resolved and our team is now in the processing of depositing the impacted funds to the affected accounts. Affected merchants should receive the delayed funds today, Sunday, 12 April, 2026.

We apologise for the inconvenience this caused and thank you for your understanding. For any queries, please contact our Customer Support team for assistance.
Posted Apr 12, 2026 - 08:18 AEST
This incident affected: Australia Same Day Funding.