Outage with online channels

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted May 12, 2026 - 15:23 AEST

Monitoring

A fix has been implemented and the issue is now resolved. We will actively monitor the online payment channels to ensure system stability with our third-party provider.

We thank you for your patience and apologise for the inconvenience this has caused.
Posted May 12, 2026 - 13:01 AEST

Identified

A third-party outage is currently impacting Online Checkout, Hosted Payments Page and Payment Links.

Merchants may experience issues processing transactions across Nuvei’s online payment channels. Customers attempting to make payments may encounter a “504 Gateway Timeout” error message during checkout.

We apologise for the inconvenience caused and are working closely with our third-party provider to restore services as quickly as possible.
Posted May 12, 2026 - 12:19 AEST
This incident affected: Payment Links, Online Checkout, and Hosted Payments Page.