Velocity for Business Program sign up error

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 16:12 AEST

Monitoring

A fix has been implemented and the issue is now resolved, we thank you for your patience as we work towards a solution.
Posted Aug 12, 2025 - 12:53 AEST

Identified

We’ve identified an issue with the Velocity sign-up form (https://tillpayments.com/offers/velocity). Merchants who have signed up are currently unable to access the “Accept offer” button in the confirmation email to accept their Velocity offer.

Our team is working diligently to resolve this, and we appreciate your patience as we work towards a fix.
Posted Aug 12, 2025 - 12:04 AEST
This incident affected: Velocity for Nvuei Business Program.