Merchant & Partner Portal service degradation

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 15:27 AEST

Monitoring

The issue is now resolved. Merchants are able to access the dashboards on the Merchant & Partner Portal as usual.
Posted Jun 23, 2025 - 11:17 AEST

Identified

We've identified an issue affecting the Merchant & Partner Portal (formerly known as the Till Portal), where some merchants may be unable to access their dashboards.

Our team is actively working to resolve the issue, and we apologise for any inconvenience this may have caused.
Posted Jun 23, 2025 - 10:30 AEST
This incident affected: Merchant & Partner Portal.