Same Day / Same Business Day Funding delay

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 08:04 AEST

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 08:03 AEST

Investigating

Due to an outage with Microsoft's Azure Synapse Analytics, there was a delay in Same Day and Same Business Day funding for transactions processed on Monday, 6 July, 2026.

The outage is now resolved. We have deposited the impacted funds to the affected accounts earlier today.

We apologise for the inconvenience caused and our team has been working closely with Microsoft to ensure system stability.

Thank you for your understanding.
Posted Jul 07, 2026 - 07:57 AEST
This incident affected: Australia Same Day Funding and Australia Same Business Day Funding.