PAX terminal outage

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 08:33 AEST

Monitoring

The issue is now resolved with Mastercard and we will monitor the system closely to ensure stability.
Posted Aug 15, 2026 - 19:12 AEST

Update

Upon further investigation, it has been confirmed that the outage was due to Mastercard. We will continue to work with the scheme to resolve the issue as soon as possible.

For merchants who are not able to process Mastercard transactions, please advise your customers to process payments with alternative methods.
Posted Aug 15, 2026 - 15:34 AEST

Update

A widespread issue from one of our 3rd party providers is now impacting all terminals, including Ingenico Move 5000, Verifone T650p, Quest QT720, in addition to the PAX fleet. Merchants may not be able to process transactions on the impacted terminals.

Our team is working to resolve with our provider to resolve the issue.

We apologise for the inconvenience this caused.
Posted Aug 15, 2026 - 15:19 AEST

Identified

We are currently experiencing an outage impacting our PAX terminals, including PAXA920, A910s, A80, A77. Merchants may experience error code “System Malfunction” when processing transactions.

Our team is investigating the root cause and trying to resolve the issue as soon as possible.

We apologise for the inconvenience this caused and thank you for your understanding.
Posted Aug 15, 2026 - 14:46 AEST
This incident affected: PAX A920 terminal, PAX A910s terminal, PAX A80 terminal, PAX A77 terminal, Ingenico Move5000 terminal, Verifone T650p terminal, and Quest QT720 terminal.