Service Impact to Cloud Applications

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted 1 month ago. Feb 28, 2025 - 11:53 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 1 month ago. Feb 28, 2025 - 11:49 AEDT

Update

Due to an unexpected outage, we are currently experiencing issues with our software application and hence are seeing a degraded performance on our Merchant Portal, Payment Links and Terminal Connect Applications. Our team is working very hard to restore things back to normal.

Thank you for your patience and understanding.
Posted 1 month ago. Feb 28, 2025 - 11:16 AEDT

Identified

We are currently investigating this issue.
Posted 1 month ago. Feb 28, 2025 - 11:09 AEDT
This incident affected: Verifone T650p terminal, Merchant & Partner Portal, and Payment Links.