For some merchants on Same Business Day Funding, part of the transactions processed on Friday, 22 August, 2025 were also impacted by the funding delay. The missing funding is expected to be processed as part of the deposit today.
We once again sincerely apologise for the inconvenience caused by the outage. Should you have any queries, please reach out to our Support team by submitting a request on our Help Centre.
Posted Aug 25, 2025 - 11:14 AEST
Monitoring
Due to a third-party outage with funding files delivery, there was a partial Same Day funding delay for transactions processed on Friday, 22 August, 2025. The funding for the missing transactions was deposited as part of the funding on Saturday, 23 August 2025.
We apologise for the inconvenience this caused again and thank you for your patience as we work towards a solution.
Posted Aug 25, 2025 - 08:40 AEST
Identified
An issue impacting Same Day Funding is identified. Merchant may experience partial funding delay for transactions processed on Friday, 22 August, 2025. Our team is working diligently to resolve the issue. We apologise the inconvenience caused and thank you for your patience.
Posted Aug 23, 2025 - 10:31 AEST
This incident affected: Australia Same Day Funding and Australia Same Business Day Funding.