Same Day Funding delay
Incident Report for Till Payments
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 08:36 AEDT
Monitoring
Funds have been deposited to the impacted accounts.
Posted Nov 24, 2024 - 10:57 AEDT
Identified
Due to an unexpected outage, merchants may experience delays in Same Day Funding for transactions processed on Friday, 22nd November 2024.

Funding will be processed into the impacted accounts today, Saturday, 23rd November, 2024.

We apologise the inconvenience this caused and thank you for your understanding.
Posted Nov 23, 2024 - 11:48 AEDT
This incident affected: Same Day Funding.