Ingenico Move 5000 terminal outage
Incident Report for Till Payments
Resolved
This incident has been resolved.
Posted Jan 04, 2025 - 08:31 AEDT
Update
The technical issue affecting merchants using Ingenico Move5000 terminals has been identified as a Telstra network outage. As a temporary solution, we advise merchants to switch to WiFi. Telstra is treating this outage as a high priority and is working to resolve it promptly.
Posted Jan 03, 2025 - 14:27 AEDT
Investigating
We are currently experiencing a technical outage impacting Ingenico Move5000 terminals. Some merchants may encounter a stuck screen while attempting to connect to their network, leaving the terminals unresponsive. Our team is working diligently to resolve the issue. Please visit our status page for the latest updates.
Posted Jan 03, 2025 - 12:55 AEDT
This incident affected: Ingenico Move5000 terminal.