Missing funding for Visa card transaction

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 15:10 AEDT

Identified

Due to an unexpected service outage with our third-party provider, some merchants may not receive the full funding for Visa card transactions processed on 17 March 2025.

The impacted funds are expected to be deposited in the next funding cycle:
- Same Day and Same Business Day Funding merchants will receive the funds today, 18 March 2025.
- Next Day Funding merchants will receive the funds tomorrow, 19 March 2025.

We apologise for the inconvenience and appreciate your patience as we work to resolve this issue.
Posted Mar 18, 2025 - 13:24 AEDT
This incident affected: Same Day Funding, Same Business Day Funding, and Next Day Funding.