Terminal service outage

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 08:33 AEDT

Identified

Due to a third party outage, there is an issue impacting all terminals. Merchants may not able to process MasterCard transactions.

To resolve the issue, please restart your terminal to continue with processing transactions.

We apologise for the inconvenience this caused and thank you for your patience as we work towards a solution with our partner.
Posted Mar 09, 2025 - 19:10 AEDT
This incident affected: PAX A920 terminal, Ingenico Move5000 terminal, and Verifone T650p terminal.