02 Oct 2025 - Same Day / Same Business Day Funding Delay

Incident Report for Nuvei

Update

We are continuing to monitor for any further issues.
Posted Oct 02, 2025 - 11:48 AEST

Monitoring

Due to a 3rd party outage, there will be a partial delay to Same Day Funding and Same Business Day Funding for selected merchants on transactions processed on Wednesday, 1 October 2025. The delayed amount is expected to be deposited into affected accounts today, 2 October 2025, together with settlements for today's transactions.

We are actively investigating the issue and working diligently to resolve it with our 3rd party provider.

In the interim, merchants are advised to refer to the TMP (https://merchant-anz.nuvei.com/) to verify the accurate funding amount.

We apologise for the inconvenience caused and thank you for your patience as we work towards a resolution.
Posted Oct 02, 2025 - 11:43 AEST
This incident affects: Australia Same Day Funding and Australia Same Business Day Funding.