Delay in Next Day Funding

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 08:47 AEDT

Monitoring

Funds for Australian merchants were deposited to the impacted accounts earlier today. We apologise again for the inconvenience this caused and thank you for your understanding as we work through the issue.
Posted Feb 25, 2025 - 15:55 AEDT

Update

Funds for New Zealand merchants were successfully deposited into the affected accounts yesterday. We are currently working with our partner to address the issue for Australian merchants on Next Day Funding.

We anticipate resolving this and disbursing funds to the impacted accounts today.
Posted Feb 25, 2025 - 09:55 AEDT

Identified

Due to an unexpected third party outage, there will be a Next Day Funding delay for transactions processed on Saturday, 22nd February and Sunday, 23rd of February. Our team is working diligently to resolve the issue and ensure that funds are deposited into the impacted accounts, latest by tomorrow, 25th of February, 2025.

We apologise for the inconvenience that this has caused and thank you for your understanding.
Posted Feb 24, 2025 - 16:34 AEDT
This incident affected: Next Day Funding.