Card Not Present service outage
Incident Report for Till Payments
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 10:56 AEST
Update
A temporary fix has been released by our service provider to resolve the issue, we are monitoring closely on the transactions status.
Posted Sep 13, 2024 - 08:46 AEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2024 - 17:44 AEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2024 - 17:43 AEST
Identified
Our team has identified a service outage from one of our service providers, affecting Till’s card-not-present solutions. When processing transactions via their online gateway, some merchants may encounter error code 3005, with the message: "Request to PSP timed out." As a temporary workaround, we recommend retrying the transaction.

Our team is collaborating closely with Fiserv to resolve this issue as soon as possible. We’ll provide updates as they become available. Thank you for your patience.
Posted Sep 12, 2024 - 17:29 AEST
This incident affected: Payment Links, Online Checkout, and Hosted Payments Page.