Partial delay to Same Day Funding

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 09:01 AEDT

Identified

Due to a third-party processing issue, certain merchants may experience Same Day funding delay for partial transactions processed on Saturday, 7 March, 2026. The funding for the missing transactions will be deposited as part of today's funding, 8 March, 2026.

We apologise for the inconvenience this caused again and thank you for your patience as we work towards a solution.
Posted Mar 08, 2026 - 14:39 AEDT
This incident affected: Australia Same Day Funding.