Online transaction processing error

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 17:32 AEST

Monitoring

A fix has been implemented to resolve the error messages. We will be actively monitoring to ensure the systems are running smoothly.
Posted Aug 27, 2025 - 15:36 AEST

Identified

An issue impacting online transactions has been detected. Merchants may experience error code "Unexpected Server Error", or "Communication error" when processing online payments via Online Checkout, Payment Links and Hosted Payments Page.

Our team is working diligently to resolve the issue and we will provide more information when it becomes available.

Thank you for your patience as we work towards a solution.
Posted Aug 27, 2025 - 13:53 AEST
This incident affected: Payment Links, Online Checkout, and Hosted Payments Page.