Same Day / Same Business Day Funding Delay

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 08:56 AEDT

Monitoring

The Reserve Bank of Australia and VISA processing issue is now resolved.

Same Day Funding and Same Business Day Funding for transactions processed on Wednesday, 28 January 2026 will resume to the usual funding schedule.

We thank you for you for your patience as we work towards a solution with the RBA and VISA.
Posted Jan 28, 2026 - 18:29 AEDT

Identified

Due to a processing issue with the Reserve Bank of Australia and VISA, there may be a potential delay for Same Day Funding and Same Business Day Funding for transactions processed on Wednesday, 28 January 2026.

We apologise for the inconvenience this caused and we are working closely with the above parties to resolve the issue.
Posted Jan 28, 2026 - 16:01 AEDT
This incident affected: Australia Same Day Funding and Australia Same Business Day Funding.