Same Day Funding delay
Incident Report for Till Payments
Resolved
This incident has been resolved.
Posted Dec 31, 2024 - 09:36 AEDT
Monitoring
All funds have now been funded to the impacted accounts. We apologise for the inconvenience this caused.
Posted Dec 30, 2024 - 18:45 AEDT
Identified
Due to an unexpected outage, merchants may experience delays in Same Day Funding for transactions processed on Saturday, 28th December 2024.

Funding will be processed into the impacted accounts today, Monday, 30th December, 2024.

We apologise for the inconvenience caused and thank you for your understanding.
Posted Dec 30, 2024 - 12:24 AEDT
This incident affected: Same Day Funding.