Payment Links service outage
Incident Report for Till Payments
Resolved
The Payment Links issue has now been resolved. All services are back to normal. Thank you for your patience.
Posted Sep 04, 2024 - 15:16 AEST
Identified
We are currently experiencing a service outage affecting Payment Links. Our team is actively working on resolving the issue. For ongoing updates, please stay tuned to our status page.
Posted Sep 04, 2024 - 14:44 AEST
This incident affected: Payment Links.