Online payments processing issue

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 14:49 AEDT

Monitoring

The issue is now resolved. We thank you for your patience as we work towards a solution with our external partner.
Posted Nov 19, 2025 - 08:46 AEDT

Identified

Due to a global Cloudflare outage, merchants may experience issues processing online transactions via Online Gateway, Payment Links or the Hosted Payments Page. Issues with accessing the Online Gateway Portal were also detected.

We are working with our external provider to revolve the issue as soon as possible and will provide updates when information becomes available.
Posted Nov 18, 2025 - 23:10 AEDT
This incident affected: Payment Links, Online Checkout, and Hosted Payments Page.