Payment Links email interruption
Incident Report for Nuvei
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 08:41 AEDT
Monitoring
AWS Global Infrastructure has been implemented and the problem with payment links request via email is now resolved.
Posted Jan 23, 2025 - 14:33 AEDT
Identified
Due to a service outage with AWS Global Infrastructure, we’re currently experiencing an issue affecting email payment requests with Payment Links via the Payment Links Portal and the Merchant & Partner Portal. Our team is actively working to resolve the issue. In the meantime, payment requests via SMS remain fully operational.
Posted Jan 23, 2025 - 10:25 AEDT
This incident affected: Merchant & Partner Portal and Payment Links.