Service Impact to Cloud Applications

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 13:08 AEDT

Monitoring

A fix has been implemented. Merchants should now be able to access the Merchant & Partner Portal and Payment Links Portal, and process transactions on the impacted Verifone T650p and PAX terminals.

We are monitoring the results and will provide updates as soon as new information becomes available.
Posted Mar 21, 2025 - 10:13 AEDT

Identified

Due to an unexpected outage, an issue has been detected impacting our cloud software applications. Merchants might be experiencing degraded performance on our Merchant & Partner Portal, Payment Links Portal, Verifone T650p and PAX terminals on Terminal Connect software.

Our team is working to restore things back to normal. We apologise for the inconvenience this has caused. Thank you for your patience and understanding as we work towards a solution.
Posted Mar 21, 2025 - 09:44 AEDT
This incident affected: PAX A920 terminal, PAX A910s terminal, Verifone T650p terminal, Merchant & Partner Portal, and Payment Links.