Terminal network issue

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 17:35 AEST

Monitoring

We are glad to let you know that Telstra network is now resumed. We will continue monitoring the network to ensure system stability.

Thank you for your understanding and patience.
Posted Jul 08, 2026 - 11:37 AEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 08, 2026 - 08:50 AEST

Identified

Due to an outage with Telstra, merchants may experience network issue with processing transactions on their terminals.

To temporary resolve the issue, we advise merchants to connect their device to the WiFi to continue business operations.

We apologise for the inconvenience caused and will provide an update once Telstra network issue is resolved.
Posted Jul 08, 2026 - 08:08 AEST
This incident affected: PAX A920 terminal, PAX A910s terminal, PAX A80 terminal, PAX A77 terminal, Ingenico Move5000 terminal, Verifone T650p terminal, and Quest QT720 terminal.