Cloud service degradation

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 14:10 AEDT

Update

The issue is now resolved.
Posted Apr 04, 2025 - 12:30 AEDT

Update

We are continuing to monitor for any further issues.
Posted Apr 04, 2025 - 10:22 AEDT

Monitoring

The incident on terminals and the Merchant & Partner Portal is now resolved. We are working diligently to resolve the issue on Payment Links.
Posted Apr 04, 2025 - 10:15 AEDT

Investigating

An issue has been detected impacting all integrated terminals on Terminal Connect payment software, Payment Links Portal and the Merchant and Partner Portal. Our team is working for a resolution.
Posted Apr 04, 2025 - 10:07 AEDT
This incident affected: PAX A920 terminal, PAX A910s terminal, PAX A80 terminal, Verifone T650p terminal, and Merchant & Partner Portal.