01 Oct 2025 - Same Day / Same Business Day Funding data display discrepancy on TMP

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 13:24 AEST

Update

We are continuing to monitor for any further issues.
Posted Oct 02, 2025 - 10:49 AEST

Monitoring

The issue has now been resolved.
Posted Oct 02, 2025 - 10:49 AEST

Identified

We are currently experiencing a data display error on TMP (https://merchant-anz.nuvei.com/) due to a third-party outage. This issue affects some Same Day Funding and Same Business Day Funding merchants, who may notice a different funding amount compared to the actual amount deposited into your bank account

Please be assured that the correct funding amount has been successfully deposited into your account on Tuesday, 30 September 2025. Our team is actively addressing the display discrepancy and working towards a resolution with our external partner.

We apologise for the inconvenience caused and appreciate your patience and understanding during this time.
Posted Oct 01, 2025 - 12:14 AEST
This incident affected: Australia Same Day Funding, Australia Same Business Day Funding, and TMP.