Next Day Funding Delay for Australian Merchants

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 10:50 AEDT

Update

Impacted funds have now been released and will be deposited into the affected accounts once the clearing process is complete.

We apologise for the disruption this may have caused.
Posted Oct 21, 2025 - 16:31 AEDT

Identified

Due to the ongoing Amazon Website Service outage, there will be a Next Day Funding delay for Australian merchants for transactions processed on Monday, 20 October, 2025.

The impacted funds are expected to be disposited to the affected accounts tomorrow, Wednesday, 22 October, 2025. We apologise for the delay this caused and thank you for your understanding.
Posted Oct 21, 2025 - 15:26 AEDT
This incident affected: Australia Next Day Funding.