Online transaction Same Day Funding Delay

Incident Report for Nuvei

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 15:29 AEST

Update

The funds have now been deposited to the impacted account, we apologise for the inconvenience that caused and thank you for your patience as we work through the incident.
Posted Apr 07, 2025 - 10:01 AEST

Monitoring

Funding for the impacted online transactions processed on Sunday, 6th April 2025 will be deposited into the affected accounts today, Monday, 7th April 2025.
Posted Apr 07, 2025 - 09:02 AEST

Investigating

Due to an unexpected outage of one of our third-party providers, merchants may experience a delay in Same Day Funding for online transactions processed on Sunday, 6th April 2025.

Our team is working diligently to resolve the issue and will share the expected deposit time for the impacted funds as soon as possible.
Posted Apr 07, 2025 - 08:25 AEST
This incident affected: Same Day Funding.