Verifone T650p terminal issue

Incident Report for Nuvei Australia and New Zealand

Resolved

This incident has been resolved.
Posted May 25, 2026 - 08:16 AEST

Monitoring

A fix has been implemented by Verifone on the terminals software, we will monitor closely with Verifone to ensure system stability.
Posted May 24, 2026 - 16:09 AEST

Identified

Due to a 3rd party outage, there is an issue impacting all standalone Verifone T650p terminals.

Merchants may not be able to process transactions with error message “SAS Upload Fail“ or error code “COMMS ERROR T703”.

We apologise for the inconvenience caused and thank you your patience as we work towards resolving the issue with our 3rd party provider.
Posted May 24, 2026 - 13:55 AEST
This incident affected: Verifone T650p terminal.